Last change
on this file since 549 was
494,
checked in by kalxas, 10 years ago
|
Added Debian files for ZOO-Kernel and ZOO-Services
|
-
Property svn:executable set to
*
|
File size:
1.1 KB
|
Line | |
---|
1 | #!/usr/bin/make -f |
---|
2 | # -*- makefile -*- |
---|
3 | |
---|
4 | %: |
---|
5 | dh $@ |
---|
6 | |
---|
7 | override_dh_auto_configure: |
---|
8 | cd zoo-project/zoo-kernel && autoconf && ./configure --with-python |
---|
9 | |
---|
10 | override_dh_auto_build: |
---|
11 | dh_auto_build --builddirectory zoo-project/zoo-kernel |
---|
12 | cd zoo-project/zoo-services/ogr/base-vect-ops && make |
---|
13 | |
---|
14 | override_dh_auto_install: |
---|
15 | dh_auto_install --builddirectory zoo-project/zoo-kernel |
---|
16 | -mkdir -p $(CURDIR)/debian/tmp/usr/lib/cgi-bin |
---|
17 | install -m755 $(CURDIR)/zoo-project/zoo-kernel/zoo_loader.cgi $(CURDIR)/debian/tmp/usr/lib/cgi-bin/ |
---|
18 | -mv -v $(CURDIR)/zoo-project/zoo-kernel/main.cfg $(CURDIR)/debian/tmp/usr/lib/cgi-bin/ |
---|
19 | install -m755 $(CURDIR)/zoo-project/zoo-services/ogr/base-vect-ops/cgi-env/ogr_service.zo $(CURDIR)/debian/tmp/usr/lib/cgi-bin/ |
---|
20 | -mv -v $(CURDIR)/zoo-project/zoo-services/ogr/base-vect-ops/cgi-env/*.zcfg $(CURDIR)/debian/tmp/usr/lib/cgi-bin/ |
---|
21 | install -m755 $(CURDIR)/zoo-project/zoo-services/ogr/base-vect-ops-py/cgi-env/ogr_sp.py $(CURDIR)/debian/tmp/usr/lib/cgi-bin/ |
---|
22 | -mv -v $(CURDIR)/zoo-project/zoo-services/ogr/base-vect-ops-py/cgi-env/*.zcfg $(CURDIR)/debian/tmp/usr/lib/cgi-bin/ |
---|
23 | |
---|
24 | override_dh_auto_clean: |
---|
25 | dh_auto_clean --builddirectory zoo-project/zoo-kernel |
---|
Note: See
TracBrowser
for help on using the repository browser.