source: trunk/docs/install/debian.rst @ 725

Last change on this file since 725 was 725, checked in by djay, 4 years ago

Fix issue with rst files displayed from Trac. Fix strings to be translated. Always use the same string in all messages.

  • Property svn:keywords set to Date Author
  • Property svn:mime-type set to text/plain
File size: 3.4 KB
Line 
1.. _install-debian:
2
3Installation on Debian / Ubuntu
4===============================
5
6Use the following instructions to install `ZOO-Project <http://zoo-project.org>`__ on Debian or Ubuntu distributions.
7
8Prerequisites
9-------------
10
11Using Debian
12......................
13
14The following command should install all the required dependancies on Debian. See the :ref:`install-prereq` section for additional information.
15
16.. code-block:: guess
17
18   apt-get install flex bison libfcgi-dev libxml2 libxml2-dev curl openssl autoconf apache2 python-software-properties subversion python-dev libgdal1-dev build-essential libmozjs185-dev
19
20Using Ubuntu
21......................
22
23On Ubuntu, use the following command first to install the required dependancies :
24
25.. code-block:: guess
26
27   sudo apt-get install flex bison libfcgi-dev libxml2 libxml2-dev curl openssl autoconf apache2 python-software-properties subversion libmozjs185-dev python-dev build-essential
28
29Then add the *UbuntuGIS* repository in order to get the latest versions of libraries
30
31.. code-block:: guess
32
33   sudo add-apt-repository ppa:ubuntugis/ppa
34   sudo apt-get update
35
36Install the geographic library as follow:
37
38.. code-block:: guess
39
40   sudo apt-get install libgdal1-dev
41
42
43Installation
44------------
45
46:ref:`install-download` ZOO-Project latest version from svn using the following command:
47
48.. code-block:: guess
49
50  svn checkout http://svn.zoo-project.org/svn/trunk zoo-project
51
52Install the *cgic* library from packages using the following command:
53
54.. code-block:: guess
55
56  cd zoo-project/thirds/cgic206/
57  make
58
59Head to the :ref:`kernel_index` directory
60
61.. code-block:: guess
62
63  cd ../../zoo-project/zoo-kernel/
64
65Create a configure file as follow:
66
67.. code-block:: guess
68
69  autoconf
70
71Run configure with the desired options, for example with the following command:
72
73.. code-block:: guess
74
75  ./configure --with-js --with-python
76
77.. note::
78   Refer to the :ref:`installation` section for the full list of available options
79
80Compile ZOO-Kernel as follow:
81
82.. code-block:: guess
83
84  make
85
86Install the ``libzoo_service.so.1.5`` by using the following command:
87
88.. code-block:: guess
89
90      sudo make install
91
92
93Copy the necessary files to the `cgi-bin` directory (as administrator
94user):
95
96.. code-block:: guess
97
98  cp main.cfg /usr/lib/cgi-bin
99  cp zoo_loader.cgi /usr/lib/cgi-bin
100
101Install ZOO ServiceProviders, for example the basic Python service (as administrator user)
102
103.. code-block:: guess
104
105  cp ../zoo-services/hello-py/cgi-env/*.zcfg /usr/lib/cgi-bin
106  cp ../zoo-services/hello-py/*.py /usr/lib/cgi-bin/
107
108Edit the *main.cfg* file as follow (example configuration):
109
110.. code-block:: guess
111
112  nano /usr/lib/cgi-bin/main.cfg
113  - serverAddress = http://127.0.0.1
114
115
116Test the ZOO-Kernel installation with the following requests:
117
118.. code-block:: guess
119
120   http://127.0.0.1/cgi-bin/zoo_loader.cgi?ServiceProvider=&metapath=&Service=WPS&Request=GetCapabilities&Version=1.0.0
121
122.. code-block:: guess
123
124   http://127.0.0.1/cgi-bin/zoo_loader.cgi?ServiceProvider=&metapath=&Service=WPS&Request=DescribeProcess&Version=1.0.0&Identifier=HelloPy
125
126.. code-block:: guess
127
128   http://127.0.0.1/cgi-bin/zoo_loader.cgi?ServiceProvider=&metapath=&Service=WPS&Request=Execute&Version=1.0.0&Identifier=HelloPy&DataInputs=a=myname
129
130
131.. note::
132
133   Such request should return well formed XML documents (OWS documents responses).
134
135.. warning::
136
137   If ZOO-Kernel returns an error please check the :ref:`kernel_config` and beware of the :ref:`install-prereq`.
138
Note: See TracBrowser for help on using the repository browser.

Search

ZOO Sponsors

http://www.zoo-project.org/trac/chrome/site/img/geolabs-logo.pnghttp://www.zoo-project.org/trac/chrome/site/img/neogeo-logo.png http://www.zoo-project.org/trac/chrome/site/img/apptech-logo.png http://www.zoo-project.org/trac/chrome/site/img/3liz-logo.png http://www.zoo-project.org/trac/chrome/site/img/gateway-logo.png

Become a sponsor !

Knowledge partners

http://www.zoo-project.org/trac/chrome/site/img/ocu-logo.png http://www.zoo-project.org/trac/chrome/site/img/gucas-logo.png http://www.zoo-project.org/trac/chrome/site/img/polimi-logo.png http://www.zoo-project.org/trac/chrome/site/img/fem-logo.png http://www.zoo-project.org/trac/chrome/site/img/supsi-logo.png http://www.zoo-project.org/trac/chrome/site/img/cumtb-logo.png

Become a knowledge partner

Related links

http://zoo-project.org/img/ogclogo.png http://zoo-project.org/img/osgeologo.png