Ticket #13 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

problem compiling zoo on Ubuntu 10.04

Reported by: nielshoffmann Owned by:
Priority: major Milestone:
Component: zoo-kernel Version: 1.0
Keywords: build ubuntu Cc:

Description

I'm having a problem getting rev 43 compiled on Ubuntu 10.04 (64-bit) I'm using the standard g++ (Ubuntu 4.4.3-4ubuntu5) 4.4.3 that comes with the distro.

I try to compile with python support like this: ./configure --with-python --without-java and ./configure completes successfully. make zoo_loader.cgi fails with make: * [service_internal_python.o] Error 1

I'm getting a bunch of warnings, of which this one seems important: cc1plus: warning: command line option "-Wstrict-prototypes" is valid for Ada/C/ObjC but not for C++

And I'm getting one error: service_internal_python.c:204: error: ‘size’ was not declared in this scope

I'm not a C programmer, but it does look like something is missing there: PyDictObject?* PyDict_FromMap(map* t){

PyObject?* res=PyDict_New( ); map* tmp=t; while(tmp!=NULL){

if(strcasecmp(tmp->name,"value")==0){

map* ttmp=getMap(t,size); if(ttmp!=NULL)

...

Not sure if that's the reason I can't build zoo-kernel?

cheers, Niels

Change History

Changed 9 years ago by djay

Hi Niels, many thanks for this feedback.

On the line where it is written :

map* ttmp=getMap(t,size); 
}}}}

You should replace per the following line : 

{{{
#!c
map* ttmp=getMap(t,"size"); 
}}}

Indeed here we search for a size key in the map.


I'm really sorry but currently in the Kansai airport it seems difficult to update the svn by now. I will try to find time on my way back to solve this bad mistake.

Let me know if replacing the string correct the issue.


Hope to hear from you,
best regards,

ps: I've answered you on the mailing list and subscribed you.

Changed 9 years ago by djay

Hi Niels, many thanks for this feedback.

Here is the correct syntaxe ....... which make my answer readable... stil trying to commit on the svn but still hard ...

On the line where it is written :

map* ttmp=getMap(t,size); 

You should replace per the following line :

map* ttmp=getMap(t,"size"); 

Indeed here we search for a size key in the map.

I'm really sorry but currently in the Kansai airport it seems difficult to update the svn by now. I will try to find time on my way back to solve this bad mistake.

Let me know if replacing the string correct the issue.

Hope to hear from you, best regards,

ps: I've answered you on the mailing list and subscribed you.

Changed 9 years ago by djay

  • status changed from new to closed
  • resolution set to fixed

The problem is fixed by rev. 44

Note: See TracTickets for help on using tickets.

Search

Context Navigation

ZOO Sponsors

http://www.zoo-project.org/trac/chrome/site/img/geolabs-logo.pnghttp://www.zoo-project.org/trac/chrome/site/img/neogeo-logo.png http://www.zoo-project.org/trac/chrome/site/img/apptech-logo.png http://www.zoo-project.org/trac/chrome/site/img/3liz-logo.png http://www.zoo-project.org/trac/chrome/site/img/gateway-logo.png

Become a sponsor !

Knowledge partners

http://www.zoo-project.org/trac/chrome/site/img/ocu-logo.png http://www.zoo-project.org/trac/chrome/site/img/gucas-logo.png http://www.zoo-project.org/trac/chrome/site/img/polimi-logo.png http://www.zoo-project.org/trac/chrome/site/img/fem-logo.png http://www.zoo-project.org/trac/chrome/site/img/supsi-logo.png http://www.zoo-project.org/trac/chrome/site/img/cumtb-logo.png

Become a knowledge partner

Related links

http://zoo-project.org/img/ogclogo.png http://zoo-project.org/img/osgeologo.png