Ticket #154 (closed task: fixed)

Opened 3 years ago

Last modified 3 years ago

ZOO Kernel failed to process your request, receiving signal 11 = SIGSEGV

Reported by: surf9 Owned by:
Priority: trivial Milestone:
Component: Development platform Version:
Keywords: Cc:

Description

Hi there

When I use ZOO.Request, I sometimes get error:

ZOO Kernel failed to process your request, receiving signal 11 = SIGSEGV

I've updated zoo-api.js file to the latest.

Any ideas how to prevent this error from occurring? Also, I noticed once the error is shown any further request returns the same error. Is there a way to clear this state so new request are in a clean state?

Thanks,

Change History

Changed 3 years ago by djay

Hi, this looks like an interesting issue.

So you mean that once your JS Service has one query failing then all the requests sent afterward also failed. This looks very strange, every request should use different variables so this should not happen. Still, I would like to know if you can provide the !Javscript code to make me able to reproduce this issue.

I hoep to hear from you.

Changed 3 years ago by surf9

You will need to go to the LINZ site, register, and generate an API key. You can try these coordinates for testing: -40.374848 175.609335 -40.344985 175.670925 -37.283333 176.25

var coordinate=inputscoordinate?value?; var url = 'https://data.linz.govt.nz/services;key=<ADD_YOUR_API_KEY_HERE>/wfs'; var serviceParam = 'WFS'; var versionParam = '2.0.0'; var requestParam = 'GetFeature?'; var typeNamesParam = 'layer-1153'; var cqlFilterParam = 'CONTAINS(GEOMETRY,POINT('+coordinate+'))';

coastline and islands service var myInputs = { service: serviceParam, version: versionParam, request: requestParam, typeNames: typeNamesParam, CQL_FILTER: cqlFilterParam }; var myRequestResult=ZOO.Request.Get(url, myInputs); var searchResult = myRequestResult.search("gml:id"); var result = ;

if(searchResult > 0) {

result = 1; 'Not in the sea';

} else {

result = 0; 'In the sea or invalid coordinate';

}

return {result: ZOO.SERVICE_SUCCEEDED, outputs: [{name:"Result", value: result}]};

Changed 3 years ago by surf9

My curl version is 7.35.0

Changed 3 years ago by surf9

I've updated to curl version 7.54.1. Still having same issue.

Changed 3 years ago by djay

Many thanks for providing the information.

I do apologize cause I realized that similar issue has been reported already there https://lists.osgeo.org/pipermail/zoo-discuss/2017-May/001622.html. I have now applied the patch to the trunk. So, I would like to invite you to run the following commands:

# Upgrade to the latest source code
svn up
# cleanup everything 
make clean
make && sudo make install

I suppose that this will solve your issue.

Changed 3 years ago by surf09

Hi.

I downloaded the latest truck and followed your instructions. I am still getting the same error message.

Changed 3 years ago by djay

So it means that I have made a mistake in the commit I have made to fix this issue.

I think that this time I will create an account then try your example locally to make sure everything is in working.

Please, stay tune, I will try my best to answer shortly.

Changed 3 years ago by surf09

Hi. How are you going regarding resolving this bug? I created another issue with trying to chain services together using Zoo API and was also getting the same error message as this bug. Might be similar issue. Cheers.

Changed 3 years ago by djay

Hi, thanks a lot for the reminder, I should have tried earlier, sorry I forgot.

After creating an account, I was able to reproduce the same error.

Nevertheless, after changing 2 lines in the source code of the service, I am able to make it successfully running, the modifications of the JavaScript service was at the end, that now looks like this:

First syntax (works):

    outputs["Result"]["value"]=result;
    return {result: ZOO.SERVICE_SUCCEEDED, outputs: outputs};

Second syntax (works):

    return {result: ZOO.SERVICE_SUCCEEDED, outputs: {"Result":{"value": result}}};

So, I suppose that this will solve your issue. Still, I think that it would be better that the ZOO-Kernel give more details about this kind of issue.

I hope this helps.

Changed 3 years ago by djay

In case you need arrays, there is also a third optional syntax that can be used which is the following:

    return [ZOO.SERVICE_SUCCEEDED,{"Result":{"value": result}}];

Changed 3 years ago by surf09

Thanks that helped.

Changed 3 years ago by djay

  • status changed from new to closed
  • resolution set to fixed

We can now close this issue.

Note: See TracTickets for help on using tickets.

Search

Context Navigation

ZOO Sponsors

http://www.zoo-project.org/trac/chrome/site/img/geolabs-logo.pnghttp://www.zoo-project.org/trac/chrome/site/img/neogeo-logo.png http://www.zoo-project.org/trac/chrome/site/img/apptech-logo.png http://www.zoo-project.org/trac/chrome/site/img/3liz-logo.png http://www.zoo-project.org/trac/chrome/site/img/gateway-logo.png

Become a sponsor !

Knowledge partners

http://www.zoo-project.org/trac/chrome/site/img/ocu-logo.png http://www.zoo-project.org/trac/chrome/site/img/gucas-logo.png http://www.zoo-project.org/trac/chrome/site/img/polimi-logo.png http://www.zoo-project.org/trac/chrome/site/img/fem-logo.png http://www.zoo-project.org/trac/chrome/site/img/supsi-logo.png http://www.zoo-project.org/trac/chrome/site/img/cumtb-logo.png

Become a knowledge partner

Related links

http://zoo-project.org/img/ogclogo.png http://zoo-project.org/img/osgeologo.png