Ticket #47 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

XML Validation issue when Default node only present in ZCFG

Reported by: djay Owned by:
Priority: major Milestone: 1.2.0
Component: zoo-kernel Version:
Keywords: Cc:

Description

I noticed that when only a Default input or output ComplexData is defined in the ZCFG, the ExecuteResponse failed to validate as it should contain a Supported node which is missing.

Change History

Changed 8 years ago by djay

  • status changed from new to closed
  • resolution set to fixed
  • component changed from Development platform to zoo-kernel

rev.280 solve this issue. Now the ZOO-Kernel use the Default informations to add a Supported node.

Changed 8 years ago by djay

  • status changed from closed to reopened
  • resolution fixed deleted

The same occurs for BoundingBoxData? nodes.

Changed 8 years ago by djay

  • status changed from reopened to closed
  • resolution set to fixed

This was not about BoudingBoxData but about Output containing only one Default node.

Changed 8 years ago by djay

ref rev.283.

Note: See TracTickets for help on using tickets.

Search

Context Navigation

ZOO Sponsors

http://www.zoo-project.org/trac/chrome/site/img/geolabs-logo.pnghttp://www.zoo-project.org/trac/chrome/site/img/neogeo-logo.png http://www.zoo-project.org/trac/chrome/site/img/apptech-logo.png http://www.zoo-project.org/trac/chrome/site/img/3liz-logo.png http://www.zoo-project.org/trac/chrome/site/img/gateway-logo.png

Become a sponsor !

Knowledge partners

http://www.zoo-project.org/trac/chrome/site/img/ocu-logo.png http://www.zoo-project.org/trac/chrome/site/img/gucas-logo.png http://www.zoo-project.org/trac/chrome/site/img/polimi-logo.png http://www.zoo-project.org/trac/chrome/site/img/fem-logo.png http://www.zoo-project.org/trac/chrome/site/img/supsi-logo.png http://www.zoo-project.org/trac/chrome/site/img/cumtb-logo.png

Become a knowledge partner

Related links

http://zoo-project.org/img/ogclogo.png http://zoo-project.org/img/osgeologo.png