Ticket #82 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Issue when using POST request in input Reference node

Reported by: djay Owned by:
Priority: major Milestone: 1.4dev
Component: zoo-kernel Version:
Keywords: Cc:

Description

I tried to use the following request and suceed with it:

<wps:Execute service="WPS" version="1.0.0" xmlns:wps="http://www.opengis.net/wps/1.0.0" xmlns:ows="http://www.opengis.net/ows/1.1" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.opengis.net/wps/1.0.0 ../wpsExecute_request.xsd">
 <ows:Identifier>getFeaturesCopy</ows:Identifier>
 <wps:DataInputs>
  <wps:Input>
   <ows:Identifier>InputEntity2</ows:Identifier>
   <wps:Reference mimeType="text/xml" xlink:href="http://127.0.0.1/np-bin/mapserv.cgi?map=/Users/djay/Sites/data/Result_79554.map&amp;SERVICE=WFS&amp;VERSION=1.0.0&amp;REQUEST=GetFeature&amp;typeName=Result&amp;__tt=Fri Aug 09 2013 00:52:34 GMT+0200 (CEST)" />
  </wps:Input>
  <wps:Input>
   <ows:Identifier>InputEntity1</ows:Identifier>
   <wps:Reference mimeType="text/xml" xlink:href="http://127.0.0.1/np-bin/mapserv.cgi?map=/Users/djay/Sites/data/public_maps/search_indicateurs_com002.map" method="POST">
    <wps:Header key="Content-Type" value="text/xml" />
    <wps:Body><wfs:GetFeature service="WFS" version="1.0.0" outputFormat="GML2" xmlns:wfs="http://www.opengis.net/wfs" xmlns:ogc="http://www.opengis.net/ogc" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.opengis.net/wfs http://schemas.opengis.net/wfs/1.0.0/WFS-basic.xsd">
      <wfs:Query typeName="com002">
       <Filter>
        <OR>
         <PropertyIsLike wildcard='*' singleChar='.' escape='!'>
          <PropertyName>num_com</PropertyName>
          <Literal>75105</Literal>
         </PropertyIsLike>
         <PropertyIsLike wildcard='*' singleChar='.' escape='!'>
          <PropertyName>num_com</PropertyName>
          <Literal>75106</Literal>
         </PropertyIsLike>
         <PropertyIsLike wildcard='*' singleChar='.' escape='!'>
          <PropertyName>num_com</PropertyName>
          <Literal>75107</Literal>
         </PropertyIsLike>
         <PropertyIsLike wildcard='*' singleChar='.' escape='!'>
          <PropertyName>num_com</PropertyName>
          <Literal>75108</Literal>
         </PropertyIsLike>
        </OR>
       </Filter>
      </wfs:Query>
     </wfs:GetFeature>
    </wps:Body>
   </wps:Reference>
  </wps:Input>
 </wps:DataInputs>
 <wps:ResponseForm>
  <wps:ResponseDocument>
   <wps:Output mimeType="image/png" asReference="true">
    <ows:Identifier>Result</ows:Identifier></wps:Output>
   </wps:ResponseDocument>
 </wps:ResponseForm>
</wps:Execute>

Nevertheless, when trying to give input references in reverse order it failed by receiving signal 11 (segmentation fault).

So, when using the following request, it failed:

<wps:Execute service="WPS" version="1.0.0" xmlns:wps="http://www.opengis.net/wps/1.0.0" xmlns:ows="http://www.opengis.net/ows/1.1" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.opengis.net/wps/1.0.0 ../wpsExecute_request.xsd">
 <ows:Identifier>getFeaturesCopy</ows:Identifier>
 <wps:DataInputs>
  <wps:Input>
   <ows:Identifier>InputEntity1</ows:Identifier>
   <wps:Reference mimeType="text/xml" xlink:href="http://127.0.0.1/np-bin/mapserv.cgi?map=/Users/djay/Sites/data/public_maps/search_indicateurs_com002.map" method="POST">
    <wps:Header key="Content-Type" value="text/xml" />
    <wps:Body><wfs:GetFeature service="WFS" version="1.0.0" outputFormat="GML2" xmlns:wfs="http://www.opengis.net/wfs" xmlns:ogc="http://www.opengis.net/ogc" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.opengis.net/wfs http://schemas.opengis.net/wfs/1.0.0/WFS-basic.xsd">
      <wfs:Query typeName="com002">
       <Filter>
        <OR>
         <PropertyIsLike wildcard='*' singleChar='.' escape='!'>
          <PropertyName>num_com</PropertyName>
          <Literal>75105</Literal>
         </PropertyIsLike>
         <PropertyIsLike wildcard='*' singleChar='.' escape='!'>
          <PropertyName>num_com</PropertyName>
          <Literal>75106</Literal>
         </PropertyIsLike>
         <PropertyIsLike wildcard='*' singleChar='.' escape='!'>
          <PropertyName>num_com</PropertyName>
          <Literal>75107</Literal>
         </PropertyIsLike>
         <PropertyIsLike wildcard='*' singleChar='.' escape='!'>
          <PropertyName>num_com</PropertyName>
          <Literal>75108</Literal>
         </PropertyIsLike>
        </OR>
       </Filter>
      </wfs:Query>
     </wfs:GetFeature>
    </wps:Body>
   </wps:Reference>
  </wps:Input>
  <wps:Input>
   <ows:Identifier>InputEntity2</ows:Identifier>
   <wps:Reference mimeType="text/xml" xlink:href="http://127.0.0.1/np-bin/mapserv.cgi?map=/Users/djay/Sites/data/Result_79554.map&amp;SERVICE=WFS&amp;VERSION=1.0.0&amp;REQUEST=GetFeature&amp;typeName=Result&amp;__tt=Fri Aug 09 2013 00:52:34 GMT+0200 (CEST)" />
  </wps:Input>
 </wps:DataInputs>
 <wps:ResponseForm>
  <wps:ResponseDocument>
   <wps:Output mimeType="image/png" asReference="true">
    <ows:Identifier>Result</ows:Identifier></wps:Output>
   </wps:ResponseDocument>
 </wps:ResponseForm>
</wps:Execute>

There should be something specific to be done to handle correctly the header setting / clearing for POST requests. Anyway, it should work whatever is the order of input references.

Change History

Changed 6 years ago by djay

  • status changed from new to closed
  • resolution set to fixed

This issue was solved in r441 by creating one dedicated CURL handle per POST requests and the other handle is used for all the GET requests.

Note: See TracTickets for help on using tickets.

Search

Context Navigation

ZOO Sponsors

http://www.zoo-project.org/trac/chrome/site/img/geolabs-logo.pnghttp://www.zoo-project.org/trac/chrome/site/img/neogeo-logo.png http://www.zoo-project.org/trac/chrome/site/img/apptech-logo.png http://www.zoo-project.org/trac/chrome/site/img/3liz-logo.png http://www.zoo-project.org/trac/chrome/site/img/gateway-logo.png

Become a sponsor !

Knowledge partners

http://www.zoo-project.org/trac/chrome/site/img/ocu-logo.png http://www.zoo-project.org/trac/chrome/site/img/gucas-logo.png http://www.zoo-project.org/trac/chrome/site/img/polimi-logo.png http://www.zoo-project.org/trac/chrome/site/img/fem-logo.png http://www.zoo-project.org/trac/chrome/site/img/supsi-logo.png http://www.zoo-project.org/trac/chrome/site/img/cumtb-logo.png

Become a knowledge partner

Related links

http://zoo-project.org/img/ogclogo.png http://zoo-project.org/img/osgeologo.png